Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#5676 closed bug (duplicate)

fadeIn/fadeOut/fadeTo leaves inline style "filter" behind in IE

Reported by: Myrlyn Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.4a1
Keywords: fadeIn, fadeOut, fadeTo, IE Cc:
Blocked by: Blocking:

Description

Using fadeIn/fadeOut leaves an inline "filter" key in the style attribute for elements effected by the fade. This causes a few problems:

1) The inline filter without a value makes the element opaque even if the CSS says it should be semi-transparent.

2) Causes a brief "flash" upon subsequent fadeIn/fadeOut/fadeTo calls where the element is briefly fully opaque.

A rewrite of the three methods that fixes this problem can be found here:

http://malsup.com/jquery/fadetest.html

Change History (3)

comment:1 Changed 9 years ago by snover

#4845 is a duplicate of this ticket.

comment:2 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by snover

Duplicate of #6652.

Note: See TracTickets for help on using tickets.