Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5673 closed bug (duplicate)

ready() callbacks fire inline after load

Reported by: SidneySM Owned by: brandon
Priority: minor Milestone: 1.4
Component: event Version: 1.4a1
Keywords: isReady ready event Cc:
Blocked by: Blocking:

Description

When an event listener is installed, the expectation is that the callback will fire sometime after the currently-executing code.

Because of this, some developers may have setup code after a call to .ready().

If this all happens before the ready event, it's not a problem, but if the ready event has already fired, the callback happens immediately (see here in 1.3.2) and code written this way will break.

It makes sense to do

setTimeout(function(){ this.call( document, jQuery) }, 0);

or similar so that the behavior of .ready() is consistent.

Change History (3)

comment:1 Changed 10 years ago by SidneySM

Typo. Code block should be:

setTimeout( function(){ fn.call( document, jQuery ) }, 0 );

comment:2 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by snover

Duplicate of #7366.

Note: See TracTickets for help on using tickets.