Bug Tracker

Opened 9 years ago

Closed 8 years ago

#5661 closed bug (wontfix)

jQuery (or sizzle?) does not return children of HTML5 sections in IE7

Reported by: tonydewan Owned by: john
Priority: minor Milestone: 1.next
Component: selector Version: 1.3.2
Keywords: html5 section ie7 Cc:
Blocked by: Blocking:

Description

jQuery (or more probably Sizzle) does not accurately return children of HTML5 <section>'s in IE7, even when using a "shiv", such as the one included in modernizr. <section>'s themselves are returned, but children are not. See here:

http://www.dev.weareabq.com/bugs/section.html

This bug appears in IE7, both standalone and in IE8 in compatibility mode. Modernizr (or similar shiv) is NOT required to recreate the bug, though it IS required to get the expected result in IE8.

I have not tested IE6 at all, nor have I looked into the core to see why this is happening.

Attachments (1)

section.html (1.2 KB) - added by tonydewan 9 years ago.
All necessary code to recreate bug

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by tonydewan

Attachment: section.html added

All necessary code to recreate bug

comment:1 Changed 9 years ago by tonydewan

I forgot to mention that using a different means of selecting sections that does not include the tag name (e.g., via a class or id for the section) actually returns correctly (assuming the shiv is in place.) I updated the linked page showing this.

comment:2 Changed 9 years ago by paul.irish

This could be merged into #5545 i think

comment:3 Changed 9 years ago by tonydewan

Most probably it could, yes. The only point that's new here is that the tag name is required to make it fail. However, #5515 references this: http://ejohn.org/blog/nodename-case-sensitivity/ which appears to be the root cause.

comment:4 Changed 9 years ago by dmethvin

Status: newopen

comment:5 Changed 8 years ago by danheberden

Milestone: 1.41.next

comment:6 Changed 8 years ago by john

Resolution: wontfix
Status: openclosed

You need to be using this particular technique in order to get it to work correctly: http://ejohn.org/blog/html5-shiv/

Note: See TracTickets for help on using tickets.