Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5639 closed bug (fixed)

Binding a function to submit() a form fails in FF 3.0.15 and Chrome

Reported by: Julian Owned by: brandon
Priority: major Milestone: 1.4
Component: event Version: 1.4a1
Keywords: form submit firefox chrome bind click Cc:
Blocked by: Blocking:

Description

Bind a click handler to a function that submits a form fails with no error in 1.4a1.

If you replace $('#the_form').submit(); with alert('something'); it works fine in both versions, so it seems to be related to submit().

This bug is reproducible in Firefox 3.0.15 on Windows and Linux as well as Chrome for Windows and Linux. The issue is not present in IE6 or IE8. The page works fine when you load it with jQuery 1.3.2. I've attached a test file.

Attachments (1)

jqform.html (531 bytes) - added by Julian 10 years ago.
test for submit event bug

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Julian

Attachment: jqform.html added

test for submit event bug

comment:1 Changed 10 years ago by Julian

This seems similar to http://dev.jquery.com/ticket/5124 - I tried the patch for that one with no success.

comment:2 Changed 10 years ago by Julian

Nope, scratch that! The patch for 5124 fixed this issue as well, so please mark this as resolved.

comment:3 Changed 10 years ago by dmethvin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.