Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5632 closed bug (fixed)

Alpha filter name in upper case is not processed properly when setting opacity

Reported by: Peter de Backer Owned by:
Priority: major Milestone: 1.4.3
Component: css Version: 1.4.2
Keywords: opacity Alpha alpha Cc:
Blocked by: Blocking:

Description

the $(element).css('opacity', 20); or a fadeTo(..) operation doesn't work if an element style is using the following style definition (IE): style="filter:progid:DXImageTransform.Microsoft.Alpha(opacity='50')"

The problem is the string 'Alpha'. Replace it with 'alpha' and it works fine. I'm not sure what the offical MS specs are about this filter name, but the MS documentation is using 'Alpha' with a capital A.

The AjaxControlToolkit.Common.js is also using the upper case 'Alpha' to set tranparancy. This makes jQuery incompatible with the MS ASP AjaxControlToolkit.

Change History (3)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledattributes

comment:2 Changed 9 years ago by dmethvin

Component: attributescss

comment:3 Changed 9 years ago by john

Milestone: 1.41.4.3
Resolution: fixed
Status: newclosed
Version: 1.3.21.4.2
Note: See TracTickets for help on using tickets.