Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5540 closed bug (invalid)

Custom easing callback not working?

Reported by: olau Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi!

According to ticket 127, it seems like it should be possible to specify a easing callback in animate(), like this:

function myEasing(...) { ... }

$("h1").animate({ left: 100}, { easing: myEasing });

But it doesn't seem to work? Also I couldn't find anything about it in the documentation?

I know it's possible to register callbacks in jQuery.easing, but I'd like to generate a callback with some randomized parameters in a closure when I start the animation, and then jQuery.easing is awkward.

Change History (2)

comment:1 Changed 10 years ago by olau

Rationale: think of the stuff in the easing plugin, rather than having separate one bounce, two bounces, three bounces etc. effects, you could make a little function that given the number of bounces returns a closure that calculates an easing effect with that amount of bouncing. Like

.animate({...}, { easing: bounceEasing(3) });

I think you can generate most of the code in the easing plugin automatically with this idea.

comment:2 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

This would best be discussed on the forum, it's not a bug.

Note: See TracTickets for help on using tickets.