Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5531 closed bug (invalid)

Toggle Flickers in IE8 for "slow" speed

Reported by: curious Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: toggle, hide, flicker Cc:
Blocked by: Blocking:

Description

In IE8, when toggling to hide the element, the background that was previously there flickers at the end of the slide if the speed is not set to "fast". If the speed is set to "fast" it does not flicker and looks perfect as intended. This flickering does not happen in Firefox.

I am a newbie and going through the tutorial "Tutorials:Getting Started with jQuery" and using the jQuery Starterkit. The CSS compatibility is "BackCompat". Here are some examples of what works and what does not work:

This flickers (default): $(document).ready(function() {

$('#faq').find('dd').hide().end().find('dt').click(function() {

$(this).next().slideToggle();

});

});

This flickers ("slow"): $(document).ready(function() {

$('#faq').find('dd').hide().end().find('dt').click(function() {

$(this).next().slideToggle("slow");

});

});

This works perfectly without any flicker ("fast"): $(document).ready(function() {

$('#faq').find('dd').hide().end().find('dt').click(function() {

$(this).next().slideToggle("fast");

});

});

Change History (1)

comment:1 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

Can you discuss this on the forum to see if it's a bug?

Note: See TracTickets for help on using tickets.