Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5523 closed bug (duplicate)

overrided toString not copied in IE by $.extend

Reported by: haayman Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

IE skips the 'toString' method in a for( var attr in objext ) loop. (http://webreflection.blogspot.com/2007/07/quick-fix-internet-explorer-and.html) therefore when an object is extended by $.extend, a toString method is not copied.

fix on line 605 in version 1.3.2 add

if( options.toString != {}.toString ) {

copy any overruled toString method target.toString = options.toString;

}

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #7467.

Note: See TracTickets for help on using tickets.