Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5489 closed bug (duplicate)

jquery 1.3.2: html() method wont work on IE 6 and 7

Reported by: radmission05 Owned by:
Priority: low Milestone:
Component: manipulation Version: 1.3.2
Keywords: 1.3.2 html() IE6 IE7 IE+ Cc:
Blocked by: Blocking:

Description

html() wont work on IR6 and 7, My codes are working well before then after i put some codes it stop working, The error says "unexpected call to method or property access", Then when i debug it, the error point to the line with appenChild() method. But im not convince, because i just add 50 lines of code i think, so when i trace back all my codes, i found the error were triggered when i use html(). Those line is to modify the page TITLE ( $("title").html("xxxxx") ), with some objects obj.html("xxxxxxx");

Change History (5)

comment:1 Changed 10 years ago by radmission05

Sample line

$("title").html($(obj).html()+ " - Welcome To XXXXXXXX");

comment:2 Changed 9 years ago by dmethvin

Resolution: worksforme
Status: newclosed

The correct cross-browser way to change the document title is through the document.title property.

comment:3 Changed 9 years ago by jitter

Component: unfiledmanipulation
Milestone: 1.3.2
Priority: majorlow
Resolution: worksforme
Status: closedreopened

comment:4 Changed 9 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 9 years ago by jitter

Duplicate of #2755.

Note: See TracTickets for help on using tickets.