Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5487 closed bug (duplicate)

animate height or width changes display mode

Reported by: orlleite Owned by:
Priority: major Milestone:
Component: effects Version: 1.3.2
Keywords: animate height width display Cc:
Blocked by: Blocking:

Description (last modified by dmethvin)

Hi!

When you add a animation to a element, the display css is changed. It's should be the correct way, but not ways. In my case, table-rows get a miss visualization when it's occurs.

I did a little change, for me it's works.

My line 4023:

if ( ( this.prop == "height" || this.prop == "width" ) && this.elem.style && this.elem.style.display != "table-row" )

Yours:

if ( ( this.prop == "height" || this.prop == "width" ) && this.elem.style )

Could be others cases like this, where jquery should not change the display mode. In my way, I verify the value of display style, but it's could be a parameter, pass in animate function, for example.

thx.

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Description: modified (diff)

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4458.

Note: See TracTickets for help on using tickets.