Bug Tracker

Opened 15 years ago

Closed 15 years ago

#548 closed bug (fixed)

Loading the metadata plugin twice causes a nasty recursion error

Reported by: [email protected] Owned by: John Resig
Priority: major Milestone: 1.1a
Component: core Version: 1.1a
Keywords: metadata, recursion, error Cc:
Blocked by: Blocking:

Description

I have a page that has the metadata plugin loaded. If the user clicks a button, I use ajax to load another page as a pop-under (the dom of the second page is loaded into the dom of the first page). If this second page has the metadata plugin loaded as well, a recursion problem occurs in both Internet Explorer and Firefox (the "get" function inside the metadata plugin calls itself until the browser complains or crashes).

Further investigation has shown that the problem is not related to the ajax call and that a simple way to reproduce the error is to place two calls to the metadata plugin:

<script type="text/javascript" src="Scripts/metadata.js"></script>

<script type="text/javascript" src="Scripts/metadata.js"></script>

Repeating the call to any other script does not produce a similar error, so there must be some sort of weird processing going on in the metadata plugin.

Although calling a script twice might be considered bad programming, the example given at the beginning of the bug is perfectly feasible.

Change History (1)

comment:1 Changed 15 years ago by joern

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.