Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5412 closed bug (invalid)

Refresh selectors

Reported by: david71rj Owned by: john
Priority: minor Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

On create a new element on screen, is need review all.

See: $('table td.even').each(function() {

$(this).css('background: red')

});

Okay, this works, but if, after, you add a new element inner this table, this don't will get red background (if even).

-TABLE-

-TR-TD-[red]

-TR-TD-

~AFTER SCRIPT, NEW:~

-TR-TD-[not red :(]

I suggest any as:

$('table td:even').every(function(){

$(this).css('background: red');

})

Then, if you add a new HTML element, this will be verified before, then apply the function relactive.

This is possible?

Bye.

Change History (2)

comment:1 Changed 10 years ago by david71rj

Sorry, don't is a bug, is a enchancement

comment:2 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is not a bug or enhancement. Please ask for help on the forums.

Note: See TracTickets for help on using tickets.