Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5407 closed bug (worksforme)

fadeOut Fails When an Element Has float:left

Reported by: DavidSalahi Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: fadeOut Cc:
Blocked by: Blocking:

Description

In this sample page: the div par1 fails to fade out when I click the text that says "Fade Out 1". However, if I first click "Show 2" and then "Fade Out 2" that works. The only difference between the two is the child divs inside div par2 are of class photo2 (instead of photo). Class photo2 is the same as photo except that it omits the float:left setting.

Attachments (1)

noleadfaucet.zip (26.3 KB) - added by DavidSalahi 10 years ago.
sample page with images

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by DavidSalahi

Attachment: noleadfaucet.zip added

sample page with images

comment:1 Changed 10 years ago by DavidSalahi

Also, try just commenting out line 59 (float:left). Then, you can click Fade Out 1 and it will work.

comment:2 Changed 9 years ago by dmethvin

Component: unfiledfx

comment:3 Changed 9 years ago by boushley

Here is a fiddle that shows things working just fine (at least it does for me in Chrome on Mac OSX) http://jsfiddle.net/boushley/XA4Mj/ I have another one that's closer to what you had using inline, but that has other problems, because you're using animations on inline elements. http://jsfiddle.net/boushley/XA4Mj/1/ Need to test on other browsers, but I think this is a worksforme.

comment:4 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed

Reproducible with 1.3.2 but not with 1.4.

Note: See TracTickets for help on using tickets.