Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5345 closed bug (invalid)

nextAll() method does not return all subsequent DOM elements in IE 7

Reported by: emeerson Owned by:
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

IE 7 is not returning subsequent siblings following the currently selected element.

Firefox and IE 8 dont seem to have this problem. I'd be glad to help reproduce.

Change History (2)

comment:1 Changed 10 years ago by emeerson

This issue is invalid - caused by user error.

My DOM was not HTML 4.0 compliant. I had something like so:

<ul

<input t=hidden <li <input t=hidden <li ...

IE 8 & FF were picking up these hidden inputs, but IE 7 does not see anything past the first hidden input in the DOM. Only <li and some other list-specific elements are allowed as children of <ul

comment:2 Changed 9 years ago by dmethvin

Component: unfiledselector
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.