Bug Tracker

Opened 11 years ago

Closed 10 years ago

#5296 closed bug (worksforme)

.offset() can cause annoying flicker or jiggle

Reported by: sswett Owned by: brandon
Priority: major Milestone: 1.4
Component: offset Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

In version 1.3.2, in the JQuery.offset = { initialize: function(), there is a test being performed for the purpose of setting variable "this.doesNotIncludeMarginInBodyOffset." The test temporarily sets "body.style.marginTop" to 1px. This will cause a flicker or jiggle in Firefox (3.5.3) if the body's top margin is anything other than 1px. It is quite noticeable if the margin is large, such as 100px.

Change History (1)

comment:1 Changed 10 years ago by snover

Resolution: worksforme
Status: newclosed

I am not able to reproduce any flickering in the latest version of Firefox 3.5 running 1.4.4.

Last edited 10 years ago by snover (previous) (diff)
Note: See TracTickets for help on using tickets.