Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5264 closed bug (invalid)

embed tags do not work anymore in IE6 with current nightly build

Reported by: jesse.a Owned by:
Priority: undecided Milestone: 1.4
Component: core Version: 1.3.2
Keywords: embed Cc:
Blocked by: Blocking:

Description

Embed tags, inserted with jQuery methods loose their attributes and are not correctly shown in IE6 environment.

Example (does not work):

$('#id').html('<embed src="http://www.odeo.com/flash/audio_player_standard_gray.swf" quality="high" width="300" height="52" allowScriptAccess="always" wmode="transparent" type="application/x-shockwave-flash" flashvars="valid_sample_rate=true&external_url=test.mp3" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed>');

Example (works perfectly):

document.getElementById('id').innerHTML = '<embed src="http://www.odeo.com/flash/audio_player_standard_gray.swf" quality="high" width="300" height="52" allowScriptAccess="always" wmode="transparent" type="application/x-shockwave-flash" flashvars="valid_sample_rate=true&external_url=test.mp3&auto_play=true" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed>';

maybe this has someting to do with the patch provided for the ActiveX bug in 1.3.2 (http://dev.jquery.com/ticket/4017)

Attachments (1)

jq_embed_breakage.html (794 bytes) - added by mikecapp 10 years ago.
Minimal demo

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by gregory80

Not currently able to reproduce in IE6 build (6.0.2900.5512) sp3. Would you be able to provide more information about your system or an reliable test case for further study?

comment:2 Changed 10 years ago by dmethvin

Closing until we get a test case; may be the same as #5447.

comment:3 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Changed 10 years ago by mikecapp

Attachment: jq_embed_breakage.html added

Minimal demo

comment:4 Changed 10 years ago by mikecapp

Resolution: invalid
Status: closedreopened

I'm seeing this with 1.4 release, IE 7.0.5730.11, Win2003 Server; .html() reliably throws on jQuery-created markup containing an <embed> with at least one attribute.

Does not throw if no attributes.

Does not throw with 1.3.2.

There does seem to be an element of randomness to the underlying IE issue, in that some embed markup causes the problem and some doesn't, but behaviour is completely consistent for a given markup string.

Originally started digging because replaceWith() has started failing with <embed> tags.

Mini-demo attached

comment:5 Changed 10 years ago by mikecapp

Appears to have been (accidentally?) fixed - I can't reproduce with 1.4.2, either with the minimal demo I posted or with our real project. I *can* still reproduce with 1.4.

comment:6 Changed 9 years ago by snover

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.