Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5197 closed bug (duplicate)

Cannot pass data to event function with live() using function (){}()

Reported by: brianfreud Owned by:
Priority: major Milestone: 1.4
Component: event Version: 1.3.2
Keywords: Cc: brianfreud
Blocked by: Blocking:

Description

$('body').live('click', function (testVar) { alert(testVar); }("bar"));

Throws an error around line 2774 of 1.3.2,

proxy.guid = fn.guid = fn.guid
proxy.guid this.guid++;

that 'fn is undefined'.

Change History (1)

comment:1 Changed 10 years ago by flesler

Cc: brianfreud added
Component: unfilledevent
Resolution: duplicate
Status: newclosed

Duplicate of #4612.

Note: See TracTickets for help on using tickets.