Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5194 closed bug (duplicate)

toggle() doesn't preserve element's display attribute

Reported by: yacoob Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a <div> that has its 'display' attribute set to 'table-cell', via CSS. Upon calling jQuery's toggle() on that element, it gets hidden with 'display: none'. After calling toggle() once more, it ends up with 'display: block' which obviously blows up the layout.

Looks like a bug.

KT.

Change History (2)

comment:1 Changed 9 years ago by dcwood

Similar for a <span>. It changes the <span> display attribute to display:block after toggle used to return visibility. However, THIS ONLY HAPPENS if the animation duration is used. If no arguments are supplied to toggle, it seems to work correctly.

comment:2 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

Duplicate of #2185.

Note: See TracTickets for help on using tickets.