Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5157 closed bug (duplicate)

Animating TBODY sets display:block which displays it at end of table

Reported by: candlerb Owned by:
Priority: minor Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: tbody display block animate Cc:
Blocked by: Blocking:

Description

If you try to animate the show/hide of a TBODY section, then the row group jumps to the end of the table (in Firefox 3.0.13 at least). This is because the element gets a style="display: block" attribute.

I'm not sure of the best way to solve this problem.

I attach a simple HTML page which demonstrates the issue, and a frig patch to jquery which fixes it by using display:table-row-group for TBODY elements (but I'm sure there must be a cleaner way of handling this). The patch isn't perfect because there is still a small visible "bounce" at the end of the slideDown().

More info in this thread: http://groups.google.com/group/jquery-en/browse_thread/thread/38ca2deb7150efeb

Attachments (2)

tbody.html (718 bytes) - added by candlerb 10 years ago.
HTML page demonstrating problem
jquery-tbody-frig.diff (1.5 KB) - added by candlerb 10 years ago.
Workaround

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by candlerb

Attachment: tbody.html added

HTML page demonstrating problem

Changed 10 years ago by candlerb

Attachment: jquery-tbody-frig.diff added

Workaround

comment:1 Changed 10 years ago by john

Component: unfilledfx

comment:4 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

Duplicate of #2185.

Note: See TracTickets for help on using tickets.