Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5139 closed bug (invalid)

slideToggle() effect makes inner contents transparent in IE7

Reported by: achu Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc: akbathey@…
Blocked by: Blocking:

Description

Hello,

I used slideToggle() method to toggle the <div> contents inside the fieldset when the <legend> text is clicked. It works fine but when the effect takes place, ie., when the <div> contents are opened or closed, the contents are visible. It looks like only the border of the <fieldset> toggles, but the <div> contents are invisible at the background. This happens only in IE7 browser. It works fine in IE8 and Firefox 3.5.2

Attachments (1)

slideToggle.jpg (156.9 KB) - added by achu 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by achu

Attachment: slideToggle.jpg added

comment:1 Changed 10 years ago by achu

Hello jQuery Developers,

Please check the attachment. I've circled the error part.You can see the "Grid" part is scrolled. When scrolling, the TextBox behind is visible still. This happens in Internet Explorer browsers before version IE8. The attached image is in IE7. Please let me know if there is any fix for this.

comment:2 Changed 10 years ago by achu

Well, I sorted out the cause. The style of the <div> is set to "position:relative". But still, it works fine in IE8.

comment:3 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.