Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5138 closed bug (duplicate)

Namespaced events sometimes get triggered when the *beginning* of the namespace matches

Reported by: Skalman Owned by: brandon
Priority: major Milestone: 1.4
Component: event Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

This bug exists if multiple namespaces for an event are specified, both when bound and triggered. When triggering, the first namespace (in alphabetical order) doesn't have to match more than the *beginning* of a bound namespace.

Demonstration of the bug:

$(window).bind("test.beginning.two", myFunc);

$(window).trigger("test.begin.two"); myFunc gets triggered, but shouldn't

More examples in the file.

Attachments (1)

jQuery-event-bug.htm (702 bytes) - added by Skalman 10 years ago.
Demonstration of the bug

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Skalman

Attachment: jQuery-event-bug.htm added

Demonstration of the bug

comment:1 Changed 10 years ago by Skalman

Could be a dupe of #5303 (or the other way around, since that was submitted after this bug). Not totally sure though. Someone with greater insight in the jQuery code should check it out.

comment:2 in reply to:  1 Changed 10 years ago by Skalman

This problem has been fixed as of jQuery 1.4a1. Either it was a dupe of #5303 (which is fixed) or it has been fixed anyway.

The bug can now be closed.

comment:3 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Dup of #5303.

Note: See TracTickets for help on using tickets.