Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#5134 closed bug (duplicate)

outerWidth(true) reports incorrectly in Safari

Reported by: alecgorge Owned by: alecgorge
Priority: major Milestone:
Component: dimensions Version: 1.3.2
Keywords: safari, 4, safari4, outerWidth, true Cc:
Blocked by: Blocking:

Description

I've been testing outerWidth on safari and the results do not appear to be correct. I did some more digging and it appears that the innerWidth is also not accommodating the width of the scroller bar in cases where you have nested divs. Firefox seems to behave correctly.

On safari the results are:

Element Outer Width

$('#elmDim').outerWidth();

=> 216

$('#elmDim').outerWidth(true);

=> 922

On Firefox the results are:

Element Outer Width

$('#elmDim').outerWidth();

=> 216

$('#elmDim').outerWidth(true);

=> 226

Change History (5)

comment:1 Changed 9 years ago by dmethvin

Owner: changed from brandon to alecgorge
Status: newpending

Can you provide a test case?

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by jitter

Milestone: 1.4
Resolution: invalid
Status: closedreopened

comment:4 Changed 8 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by jitter

Duplicate of #3333.

Note: See TracTickets for help on using tickets.