Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5129 closed bug (invalid)

Class selector on Internet Explorer 8 not functioning as expected

Reported by: sniper506th Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a <ul> list of items dynamically created by using javascript to manually create the elements (as opposed to calling a server script and "injecting" html). Each list item has two links, a delete link and an edit link, classed as "dellink" and "editlink" respectively. Both have event handlers (i.e. $('.dellink').click() and $('.editlink').click() are assigned).

On every browser except Internet Explorer (6+), these events work as expected. However, on IE, only the first list item's edit link actually fires an event, and it fires both the edit and delete event for the last list item. None of the other edit/delete buttons fire an event. I've tried making the event selectors more and less specific, etc., but nothing seems to work.

Change History (2)

comment:1 Changed 10 years ago by kswedberg

need: ReviewTest Case

Can you please provide a test case for this? It's hard to know exactly what the issue is without seeing what you're doing. If you a server to post something to publicly, use jsbin.com and paste the url here.

thanks.

comment:2 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Please reopen if you can provide a complete test case.

Note: See TracTickets for help on using tickets.