Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5091 closed bug (wontfix)

Attribute type of "multiple" in chrome/safari/firefox

Reported by: assertfail Owned by:
Priority: blocker Milestone: 1.5
Component: attributes Version: 1.5
Keywords: Cc: miketaylr
Blocked by: Blocking:

Description (last modified by dmethvin)

For instance if you have an input with id "someid" with a custom attribute "multiple" that has the value "True", then the following evaluates to true: (typeof $("#someid").attr("istrue"))==="boolean" in chrome.

Attachments (1)

chrome.htm (1.2 KB) - added by assertfail 10 years ago.
A file that helps demonstrating the inconsistancy

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by assertfail

Attachment: chrome.htm added

A file that helps demonstrating the inconsistancy

comment:1 Changed 9 years ago by dmethvin

Component: unfiledattributes
Description: modified (diff)
Summary: Attribute type inconsistency in chromeAttribute type of "multiple" in chrome/safari/firefox

Repro in Firefox 3.6, Chrome 5 and Safari 5, but not IE 8. jQuery is not causing this, it's present in the native DOM. I think what is happening is that since multiple is a boolean property of the select element, there is some common DOM code in the browser that is processing this attribute for input elements as well.

It's always a very good idea to avoid any names that are used by DOM elements, see http://yura.thinkweb2.com/domlint/ for some examples.

I'll leave this open for the moment but I'm not sure there's anything jQuery can/should do about it.

comment:2 Changed 9 years ago by Rick Waldron

Milestone: 1.41.4.5
Priority: minorblocker
Status: newopen

Confirmed;

Expect: ["True", "string"], ["False", "string"]

IE:     ["True", "string"], ["False", "string"]
Opera:  ["True", "string"], ["False", "string"]

Chrome: [ true, "boolean"], ["False", "string"]
FF:     [ true, "boolean"], ["False", "string"]
Safari: [ true, "boolean"], ["False", "string"]

http://jsfiddle.net/rwaldron/fjXFw/4/

Last edited 9 years ago by Rick Waldron (previous) (diff)

comment:3 Changed 9 years ago by Rick Waldron

Resolution: wontfix
Status: openclosed

multiple="True" is not a valid attribute on input type="text", nor is true a valid value for this attribute.

comment:5 Changed 9 years ago by john

Version: 1.3.21.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:6 Changed 9 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.