Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5082 closed bug (worksforme)

toggle has unexpected behavior in IE8

Reported by: aakoch Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: toggle, ie8 Cc:
Blocked by: Blocking:

Description

This is hard to explain.

Short story: toggle() doesn't toggle the selected elements sometimes.

Long story: I have 3 links on a page, A, B, C. When the page is loaded, links A and C are visible. Clicking on link A hides A and C and shows B. Clicking on B shows A and hides B, but C is still hidden. Clicking on A will now hide A and show B and C.

I've tested in in FF3, Safari, Opera 9, and IE8 compatibility mode and they all work as expected.

I'm attaching the test, but it is also hosted at http://adamkoch.com/jquery_toggle_test2.html

Attachments (1)

jquery_toggle_test2.html (1.3 KB) - added by aakoch 10 years ago.
test

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by aakoch

Attachment: jquery_toggle_test2.html added

test

comment:1 Changed 10 years ago by nbr

Might be related to #4737.

comment:2 Changed 10 years ago by john

Component: unfilledfx

comment:3 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed

test case works for me jQuery 1.4.4.

Note: See TracTickets for help on using tickets.