Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5078 closed bug (duplicate)

More Selector Strangeness

Reported by: morgancodes Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3
Keywords: selector oddity Cc:
Blocked by: Blocking:

Description

Similar to http://dev.jquery.com/ticket/4748

In the following example, FireFox finds three nodes, IE7 finds none.

HTML FILE

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">

<html lang="en">
<head>
        <script type="text/javascript" src="http://jqueryjs.googlecode.com/files/jquery-1.3.2.min.js"></script>
</head>
<body>
<script>

var xml;
$.ajax({
  type: "GET",
  url: "data.xml",
  success: function(data){
      var query1 = $("CI,CF", data).length;
      var msg = '$("CI,CF", data).length: ' + query1;
      alert(msg);
  }
});


</script>
</body>
</html>

XML FILE

<?xml version="1.0" encoding="ISO-8859-2"?>
 <CNs>
   <CI>
   </CI>
   <CF>
   </CF>
   <CI>
   </CI>
 </CNs>


Change History (2)

comment:1 Changed 9 years ago by addyosmani

Keywords: selector oddity added
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by addyosmani

Duplicate of #4748.

Note: See TracTickets for help on using tickets.