Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5070 closed bug (duplicate)

parents() not working the same with Firefox 3.5.2

Reported by: rhorn Owned by: john
Priority: minor Milestone: 1.3.2
Component: selector Version: 1.3.2
Keywords: parents Cc:
Blocked by: Blocking:

Description

Not sure if this is related to jQuery or the update, but parents("SELECTOR") no longer finds elements with tag attributes defined across multiple lines.

Example, the following worked for me before the update, but does not work now:

<div class="testParent

secondClass">

<div class="child1"></div>

</div>

<script type="text/javascript">

$('.testChild').parents('.testParent').click(function(){

alert('gets here');

});

</script>

The following does work: <div class="testParent secondClass">

<div class="child1"></div>

</div>

<script type="text/javascript">

$('.testChild').parents('.testParent').click(function(){

alert('gets here');

});

</script>

Change History (2)

comment:1 Changed 10 years ago by rhorn

Not sure if this is related to jQuery or the update, but parents("SELECTOR") no longer finds elements with tag attributes defined across multiple lines.

Example, the following worked for me before the update, but does not work now:

<div class="testParent

secondClass">

<div class="testChild"></div>

</div>

<script type="text/javascript">

$('.testChild').parents('.testParent').click(function(){

alert('gets here');

});

</script>

The following does work: <div class="testParent secondClass">

<div class="testChild"></div>

</div>

<script type="text/javascript">

$('.testChild').parents('.testParent').click(function(){

alert('gets here');

});

</script>

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4761.

Note: See TracTickets for help on using tickets.