Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5064 closed bug (invalid)

G.replace throws an exception

Reported by: dnlstffrd Owned by:
Priority: minor Milestone: 1.3.2
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

In jquery-1.3.2.min.js, the following line throws an exception for me: G = G.replace(/-([a-z])/ig, function(M, N) { return N.toUpperCase() });

I'd recommend adding in a check like if(typeof(G) == 'string') or something to make sure this doesn't happen.

Change History (1)

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

That error is from the minimized jQuery. Most likely it is due to bad input being passed to jQuery from the code on the page or from a plugin. Please reopen this ticket if you can create a test case that reproduces the problem and it seems to be due to a jQuery bug.

Note: See TracTickets for help on using tickets.