Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#506 closed bug (worksforme)

event error in 1.0.4

Reported by: nedarb@… Owned by:
Priority: major Milestone: 1.1a
Component: event Version: 1.0
Keywords: Cc:
Blocked by: Blocking:

Description

I get the following error only in Firefox 2.0 when I register a function on $(document).ready(): [ERROR] event has no properties fix(undefined)jquery.js (line 1024) handle(undefined)jquery.js (line 986) onload()reflection.js (line 170) [Break on this error] event.preventDefault = function() { [END ERROR]

Change History (4)

comment:1 Changed 14 years ago by brandon

Component: fxevent

An example page would be nice. What is reflection.js?

comment:2 Changed 14 years ago by nedarb@…

The error is when you use the Reflection.js class in conjunction with jQuery.

comment:3 Changed 14 years ago by brandon

Resolution: worksforme
Status: newclosed

I have built a test case using the reflections.js testsuite.html and REV 737 of jQuery. I added a click event to each img.reflect to alert the class name of the element in $(document).ready(). I was unable to reproduce the error.

Please feel free to reopen with a test case.

comment:4 Changed 14 years ago by brandon

Forgot to post the link to the test case I setup: http://brandon.jquery.com/testing/reflections/testsuite.html

Note: See TracTickets for help on using tickets.