Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5041 closed bug (duplicate)

WrapAll removed dynamically applied check state in IE6

Reported by: johnallan Owned by:
Priority: minor Milestone: 1.4
Component: manipulation Version: 1.3.2
Keywords: ie6 wrapall checkbox Cc:
Blocked by: Blocking:

Description

This is only in IE6.

The page I am working on sets the checked state of check boxes using attr("checked","checked"); This works fine. However if you apply this to a checkbox, then use WrapAll to wrap the checkbox it wraps but the checkbox does not retain it's checked state and does not return true to the :checked filter. All other browsers it is fine but might be worth noting as it took a few hours for me to figure out what the problem was in IE6.

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledmanipulation

Unfortunately, IE does not maintain the checked state of a check box when the DOM appendChild method is used.

comment:2 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #769.

Note: See TracTickets for help on using tickets.