Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5032 closed bug (duplicate)

Crash in the W3C box model check when using jQuery UI or Interface

Reported by: fletch Owned by:
Priority: minor Milestone: 1.4
Component: support Version: 1.3.2
Keywords: document.body Cc:
Blocked by: Blocking:

Description

Crash at jquery-1.3.2.js line 3204.

document.body is null or not an object.

not sure how this comes about, since the line that crashes is inside a jQuery(function() {}); call. document.body should be ready by then, shouldn't it?

the crash also occurs when iutils.js (from Interface) is used with the jQuery core. Which is interesting - is that based on the same code, maybe?

I am developing for a specific browser so I have modified the function to simply return true for W3C box model support. So a fix is not urgent.

I am also raising this on the jQuery ui.core bug tracker.

Change History (7)

comment:1 Changed 10 years ago by dmethvin

Please attach a test case.

comment:2 Changed 10 years ago by fletch

Hi dmethvin, what exactly do you mean by "attach a test case"? I can't provide our exact code including all the asp.net, etc etc. If I just paste what I have it won't run! Here's a better description of how to repro the bug:

  • include the 1.3.2 code in conjunction with either the core jquery UI or iutils.js (in an asp.net page or other serverside tech).
  • reload the page repeatedly at short (~1s) intervals.

note that you don't need to call any jquery functions for the bug to appear - it happens during the jquery library initialization (apparently).

Thanks! fletch

comment:3 Changed 10 years ago by mshaver

We see the same bug with our application also. It is not consistently reproducable, but occurs often enough that we are considering changing JQuery source code to resolve the issue.

One additional note; this is only reproducable for us against IE 6 with caching completely disabled.

Internet Options > General > Temporary Internet Files > Settings -> "Check for new versions of stored pages:" -> Every visit to the page.

Symptoms are similar to what is already described. A consumer of our Java application is opening the app in an IFrame contained within a VB application. The VB application is quickly changing URLs against the IFrame directly. Occationally JQuery has difficulty running the W3C box model test.

comment:4 Changed 10 years ago by mshaver

Some more information on this problem.

  1. This appears to be an IE6 bug as I am able to reproduce the same issue against the dojo library.
  1. This is reproducable against the JQuery web site using IE6.

The following Visual Basic Script can be used to reproduce the issue:

Set objExplorer = wscript.CreateObject("InternetExplorer.Application","IE_")
objExplorer.Visible = true
e = 0
do while e < 160 : 
	e=e+1
	objExplorer.Navigate "http://docs.jquery.com/Main_Page"
	wscript.sleep 750
loop

Obviously this is not typical behaviour for a user, but it would appear that it is something that should be guarded against if JQuery is to support IE6. I can in fact reproduce this without using a script if I simply change URLs quickly by hand.

Again, this is only reproducable with IE6. I am using IE6 SP3. 6.0.2900.5512.xpsp_sp3_gdr.090206-1234

Apologies for pounding the JQuery website yesterday @ 6:30.

comment:5 Changed 10 years ago by mshaver

Another update on this bug. A potential work around which will have minimal impact is to move the JQuery and/or Dojo imports to the body section of your html DOM. This problem is only reproducable for me if the JQuery import resides is the Head of my DOM.

comment:6 Changed 10 years ago by elbrus

Hi,

i just got the same error in IE8 (Version: 8.0.6001.18702). I'm using jQuery v1.3.2.

My situation:

  1. I'm opening modal pop-up with iframe in my page (lytebox plugin).
  2. On iframe PostBack it makes some stuff (not important here) and destroys iframe. Seems, that everything is working without any problems. But later I'm enabling script debugger, and the same action gives me this error. Btw, in compatibility view it gives the same error too.
  3. Iframe is destroyed, everything is ok. Only that error message is hanging around.

It's not important for a simple web page users, because I believe, that their script debugger is disabled :) But it would be great, if you could find a fix for it.

comment:7 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4320.

Note: See TracTickets for help on using tickets.