Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5022 closed enhancement (duplicate)

strings of markup and application/xml

Reported by: jablko Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Attachments (1)

patch (552 bytes) - added by jablko 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by jablko

Attachment: patch added

comment:1 Changed 10 years ago by dmethvin

Component: unfilledcore

Perhaps you'd want to see if the context, rather than the div, is xml?

comment:3 Changed 10 years ago by jablko

.innerHTML doesn't work in non-HTML documents, I think handling the exception with DOMParser() allows some current tests which fail with test/xhtml.php (Content-Type: application/xhtml+xml) to pass, e.g. test/unit/manipulation.js "html(String)"

Here's a new test, http://www.sfu.ca/~jdbates/tmp/jquery/201004090/patch

Without this change it passes with test/index.html but fails with test/xhtml.php - with this change it passes with both

comment:4 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This patch is too magical for my taste, it's very difficult to tell xml from html and wrapping a try/catch around it is going to cause trouble no doubt.

I'm closing this as a dup of #4617 which asks for xml support but takes a different approach.

comment:5 Changed 9 years ago by dmethvin

Duplicate of #4617.

Note: See TracTickets for help on using tickets.