Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5014 closed bug (duplicate)

IE8 bug $(element).append() bug with multiple TEXT params

Reported by: vamp Owned by:
Priority: critical Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc: vamphouse@…
Blocked by: Blocking:

Description

$('<div />').append(',?')

appears an Error:

Line: 957 Error: Invalid argument.

#957: fragment.appendChild( ret[i] );

but code:

var r = $('<div />'); $.map([',?'], function(f){ r.append(f); });

works fine!

Attachments (1)

shot.png (19.9 KB) - added by vamp 10 years ago.
ie debugger notification

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by vamp

Attachment: shot.png added

ie debugger notification

comment:1 Changed 10 years ago by pbcomm

Can you provide an example page?

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4011.

Note: See TracTickets for help on using tickets.