Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5002 closed bug (duplicate)

$.EACH utility LENGTH property bug

Reported by: mruzicka Owned by:
Priority: major Milestone:
Component: core Version: 1.3.2
Keywords: each loop length Cc:
Blocked by: Blocking:

Description

When using $.each utility on object with .length property $.each function fails to run.

Change History (8)

comment:1 Changed 10 years ago by mruzicka

When using $.each utility on object with .length property $.each function fails to run.

ITS FREAKING CRITICAL LINE 666 BUG RAISED FROM HELL!

comment:2 Changed 10 years ago by xpuu

Probably fixed in SVN now http://dev.jquery.com/ticket/2827

But still this seems to me quite weirdo way, how to find out, that something is not array...

core.js: 356: isObj = length === undefined
jQuery.isFunction(object)

aflesler 20.6.2009 16:51:19 jquery core: Closes #2827. jQuery.each iterates over functions

comment:3 Changed 10 years ago by dmethvin

Component: unfilledcore
Priority: criticalmajor

$.each wants to treat array-like objects as arrays, e.g. nodelists and function arguments.

comment:4 Changed 9 years ago by addyosmani

Keywords: needsreview added
Status: newopen

comment:5 Changed 9 years ago by addyosmani

Milestone: 1.3.2

comment:6 Changed 9 years ago by addyosmani

Resolution: duplicate
Status: openclosed

comment:7 Changed 9 years ago by addyosmani

Duplicate of #2827.

comment:8 Changed 9 years ago by dmethvin

Keywords: needsreview removed
Note: See TracTickets for help on using tickets.