Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4984 closed bug (duplicate)

IE select .val() and form reset

Reported by: FarSeeing Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

If select is located in form and the first option doesn't have selected attribute, then .val() after form reset will return none.

Tested in IE 6, 7, 8.

In attached demo try getting values, then reset form and get values again.

Attachments (1)

test.html (1011 bytes) - added by FarSeeing 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by FarSeeing

Attachment: test.html added

comment:1 Changed 10 years ago by tinyfly

Could this be a duplicate of #2551

comment:2 Changed 10 years ago by john

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.