Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4965 closed bug (duplicate)

Whitespace in class attribute causes selector trouble.

Reported by: brendo_ Owned by: john
Priority: minor Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

See the attached testcase is probably the easiest way to understand this bug.

Pretty much, the $('.field-date') finds the correct elements, but then in the each loop, $(this).hasClass('.field-date') fails when there is extra whitespace between the classes.

I think there might be two bugs here, because the original $('.field-date') finds the correct elements regardless of whitespace, but then hasClass chokes on the whitespace.

A pure JS test is provided too, which shows the correct results (two raw:true's)

Attachments (1)

testcase.html (1.5 KB) - added by brendo_ 10 years ago.
Test Case (jQuery not provided)

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by brendo_

Attachment: testcase.html added

Test Case (jQuery not provided)

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4761

Note: See TracTickets for help on using tickets.