Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4947 closed bug (duplicate)

Array.prototype.slice() required argument

Reported by: jnorell Owned by:
Priority: minor Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Arra.prototype.slice slice Cc:
Blocked by: Blocking:

Description

In ECMA-262 15.4.4.10, slice is required to have a "start" argument, but jquery sometimes calls it with no arguments. It seems to work fine in iceape, but errors in Ant Galio browser.

Attachments (1)

jquery132.slice.patch (1.4 KB) - added by jnorell 10 years ago.
patch for 1.3.2 that adds missing "start" parameter to Array.prototype.slice() calls

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by jnorell

Attachment: jquery132.slice.patch added

patch for 1.3.2 that adds missing "start" parameter to Array.prototype.slice() calls

comment:1 Changed 10 years ago by john

Component: unfilledcore
Milestone: 1.3.21.3.3
Resolution: fixed
Status: newclosed

Fixed in SVN rev [6484]. (I missed your patch - but it ended up missing a couple cases, and I've fixed those.)

comment:2 Changed 10 years ago by john

Resolution: fixed
Status: closedreopened

comment:3 Changed 10 years ago by john

Resolution: duplicate
Status: reopenedclosed

Duplicate of #4942.

Note: See TracTickets for help on using tickets.