Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4911 closed bug (invalid)

IE8 Object Required + Object doesn't support propertie or method Error

Reported by: wiliamgirard Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: IE8 Object Required Bug Cc:
Blocked by: Blocking:

Description

Error Details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6) Date/time: Thu, 16 Jul 2009 11:17:11 UTC

Message: Object Required Line: 2339 Character: 2 Code: 0 URI: http://127.0.0.1/products/INTEQengine/framework/resources/frameworkLibrary_9.2.029.7.151740044_9.7.151740.ijs

Message: Object doesn't support propertie or method Line: 11398 Character: 7 Code: 0 URI: http://127.0.0.1/products/INTEQengine/framework/resources/frameworkLibrary_9.2.029.7.151740044_9.7.151740.ijs

So, the first error occurs in jQuery Lib, here is the function:

var isXML = function(elem){

return elem.nodeType === 9 && elem.documentElement.nodeName !== "HTML"
!!elem.ownerDocument && isXML( elem.ownerDocument );

Error 1 occur here, he try to access elem.documentElement.nodeName, but elem doesn't has the property documentElement or ownerDocument.

};

And the other is in our lib, here is the function:

EnvironmentManager.prototype.getDialogs = function( id ) {

var ar = new Array() var document = this.getDocument() if ( document ) {


if ( obj1 && obj1.length ) {

ar.push( obj1 )

}

} var obj2 = $( "#" + id ) if ( obj2 && obj2.length ) {

ar.push( obj2 )

} return ar

}

This error doesn't occur in IE7, FF3, Safari and IE8 compatibility mode IE7.

Change History (4)

comment:1 Changed 10 years ago by dmethvin

Can you provide a complete test case?

comment:2 Changed 10 years ago by wm_eddie

I'm not a hundred percent sure, but I think this might be caused by calling find while a document is still loading.

I stated seeing this error in IE8 when using multiple iframes.

Is adding a simple check for elem.documentElement before accessing nodeName incorrect behavior?

comment:3 Changed 10 years ago by wm_eddie

I think this bug should be closed as not a bug.

In the multiple iframe case, this bug is triggered because I was trying to search though the contents of the iframes inside of a $(document).ready which runs when the DOM of the parent page is loaded. What I wanted was to run it on $(window).load instead, which runs only after everything on the page is loaded. This seems to have fixed my problem, and I no longer see this error.

comment:4 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Closed per your request.

Note: See TracTickets for help on using tickets.