Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4871 closed bug (worksforme)

:last selector problem

Reported by: OneManSaint Owned by: john
Priority: minor Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: last selector Cc:
Blocked by: Blocking:

Description

I have a couple of sets of nested lists, when using the :last selector to find the last li's in the nested ul's i only seem to be able to grab the very last one.

An example of the problem is available here

http://jsbin.com/onaye

I'm sure both "third pages" should have a red border.

Change History (3)

comment:1 Changed 10 years ago by OneManSaint

Updated with a work around that works as i would expect here

http://jsbin.com/ugoze

comment:2 Changed 10 years ago by mikecapp

The result in your example looks right to me. Did you want ":last-child" rather than ":last"?

comment:3 Changed 10 years ago by davidserduke

Resolution: worksforme
Status: newclosed

I agree with mikecapp that you seem to want :last-child. Find the docs here:

http://docs.jquery.com/Selectors/lastChild

Note: See TracTickets for help on using tickets.