Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#4831 closed bug (duplicate)

show() can trigger flash reload bug in Firefox 3.5

Reported by: dil Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery can trigger a bug in Firefox 3.5rc3 where show() causes all flash elements on a page to be reloaded. Bug info:

https://bugzilla.mozilla.org/show_bug.cgi?id=499433

The bug is triggered by calling show() on any table component element (TR, TD, TH, THEAD, TFOOT, and TBODY) on a page with flash. show() will call a code path that effectively does the following and causes the bug:

$('<tr/>').appendTo('body').remove();

The Firefox behavior is clearly some sort of bug but there is a fix that can be done in jQuery. show() adds empty elements to BODY to get the CSS display property. These can instead be added to a temporary DIV in BODY. A patch to 1.3.2 is attached.

Attachments (1)

jquery-1.3.2-fix-ff3.5-flash.diff (1.0 KB) - added by dil 10 years ago.
patch

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by dil

patch

comment:1 Changed 8 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by addyosmani

Duplicate of #4872.

Note: See TracTickets for help on using tickets.