Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4810 closed bug (duplicate)

JSONP Ajax repeat complete call

Reported by: Connorhd Owned by:
Priority: major Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

On success a JSONP appears to call the complete callback twice.

This appears to be because complete() is called when the tmp function is executed and when the onreadystatechange poll ends.

See attached example

Attachments (2)

jquery.png (24.0 KB) - added by Connorhd 10 years ago.
test.htm (947 bytes) - added by Connorhd 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Connorhd

Attachment: jquery.png added

Changed 10 years ago by Connorhd

Attachment: test.htm added

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #5383.

Note: See TracTickets for help on using tickets.