Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4807 closed bug (fixed)

Offline $.ajax call in IE$ get response as String

Reported by: ikkyu Owned by:
Priority: low Milestone: 1.5
Component: ajax Version: 1.4.4
Keywords: offline, ajax, IE, xml Cc:
Blocked by: Blocking:

Description

description: Offline ajax call to an offline local html or xml file get response as String, not xml document, and cannot be use with selectors.

reproduction step:

  • write ajax call to an offline local html/xml file.
  • execute the html/script locally (not via server) in IE6
  • The response data type is a String. A selector cannot be applied to the data.
  • If specified dataType:"xml", it will call error function. But the response text is the same data string.

I search the Internet and found a website that describe exactly the same problem with a workaround.

http://stackoverflow.com/questions/436670/local-html-file-ajax-call-and-jquery-woes

Change History (6)

comment:1 Changed 9 years ago by dmethvin

Milestone: 1.4
Priority: majorlow
Status: newopen

comment:2 Changed 8 years ago by manuel.richarz@…

Using jQuery 1.4.4 and have exactly the same problem. The Workaround found in the posted Link work fine.

comment:3 Changed 8 years ago by Rick Waldron

Keywords: ajaxrewrite added

comment:4 Changed 8 years ago by jaubourg

Resolution: fixed
Status: openclosed

The new ajax implementation will automagically parse text as xml if dataType: "xml" has been specified. It's part of a much broader dataType conversion architecture.

comment:5 Changed 8 years ago by jitter

Keywords: ajaxrewrite removed
Milestone: 1.5
Version: 1.3.21.4.4

comment:6 Changed 8 years ago by jitter

#3598 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.