Bug Tracker

Opened 10 years ago

Closed 9 years ago

#4770 closed bug (fixed)

JQuery extend does not copy date objects

Reported by: bernie.kovacic@… Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

JQuery.extend does not copy Date Objects correctly. ex.

var newObj = {

newDate: new Date(), deepObj: {

newerDate: new Date() }

};

var copyObj = jQuery.extend(true,{},newObj);

empty objects are returned instead of copies of the dates

Change History (3)

comment:1 Changed 10 years ago by dmethvin

Component: unfilledcore

comment:2 Changed 10 years ago by dmethvin

See also #4192.

comment:3 Changed 9 years ago by addyosmani

Resolution: fixed
Status: newclosed

Reproducing your original code in this Live test http://jsfiddle.net/addyosmani/jGHWn/3/ I can verify that 1.3.2 wasn't correctly returning the values of the deepObj or copyObj objects.

This has been corrected since 1.3.2 and if you run the test with 1.4.2 enabled in jsFiddle you will see that the correct date (object accessed) values are being output now.

Note: See TracTickets for help on using tickets.