Bug Tracker

Opened 10 years ago

Closed 9 years ago

#4766 closed bug (wontfix)

input:hidden bug (?)

Reported by: maxbnet Owned by:
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery("input:hidden") fails if input has these css properties (border & display)

input.inputbug {

display:block; border:1px solid #fff;

}

http://maxb.net/scripts/input_hidden_bug/test-1.3.2.html

Change History (3)

comment:1 Changed 10 years ago by Abro

That's not a bug. How could jQuery determine if you expect:

  • ":hidden" == ":not(:visible)" or
  • ":hidden" == "[type=hidden]" ?

By definition it's the first. Just take a look at the docs. There is no such form-selector atm., sorry.

comment:2 Changed 9 years ago by dmethvin

Component: unfiledselector

Abro, both types of elements are considered to be hidden. However, this case is a bit too bizarre for my taste. Don't style hidden inputs!

There are several checks/filters for :hidden elsewhere in jQuery fx; if this is fixed it may have other impacts.

comment:3 Changed 9 years ago by snover

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.