Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4754 closed bug (duplicate)

jQuery 1.2.6 reports wrong browser version.

Reported by: a6hi5h3k Owned by: joern
Priority: major Milestone:
Component: web Version: 1.2.6
Keywords: browser, version Cc:
Blocked by: Blocking:

Description

In jquery-1.2.6.js, it tries to extract the browser version from navigator.userAgent

version = (navigator.userAgent.toLowerCase().match( /.+(?:rv|it|ra|ie)[\/: ]([\d.]+)/ )
[])[1];

My version of IE, gives following value for userAgent:

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6; User-agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; http://bsalsa.com); .NET CLR 1.1.4322; .NET CLR 2.0.50727

As it says, its IE 7, but the eager fetching by the regex used, generates the value as 6.

As clearly mentioned in 1.3 release notes, jquery doesn't use browser detection anymore. But since my guess is, most of users might have not yet upgraded to it, so thought of reporting it.

Change History (1)

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #2661.

Note: See TracTickets for help on using tickets.