Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4735 closed bug (invalid)

"Too much recursion" in FF3 after ugrading from 1.2.6 to 1.3.2

Reported by: toth.radoslav Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

after ugrading from 1.2.6 to 1.3.2 and no change to the rest of the code, I received a "Too much recursion" error in FF3.

The code that was evoking the problem is this:

Language Selection $(".dropdown_flag").click(function() {

$(".languages").slideToggle("fast"); $(this).toggleClass("open"); return false;

});

The problem is caused by the "slideToggle" line.

Change History (1)

comment:1 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is most likely not a bug in jQuery, although you haven't provided a test case.

Often, "Too much recursion" bugs are caused by not anticipating that an event will bubble up from child elements. More events bubble up in 1.3.x than did in 1.2.x.

Other solutions can be found by searching for "jQuery too much recursion"; there are several plugins that seem to cause trouble.

Note: See TracTickets for help on using tickets.