Bug Tracker

Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#4707 closed bug (fixed)

Updating opacity in Internet Explorer breaks other currently used filters

Reported by: aheckmann Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: opacity css curCSS filter Cc:
Blocked by: Blocking:

Description

In jQuery 1.3.3pre and previous, there exists a bug in how opacity is set in Internet Explorer. If there are other filters besides alpha(opacity) being used on the element, they are overwritten.

The fix is to change jQuery.style (1.3.3pre) to first check if there are filters being used and then apply the regx replace on the result. If changeset 6349 is included we'll get the ability to not overwrite filters added inline or in the stylesheet too.

http://aaronheckmann.net:8080/jQuery/bug/iefilter/ http://dev.jquery.com/changeset/6349

Attachments (2)

fix.txt (1.5 KB) - added by aheckmann 11 years ago.
The fix
jQuery.style.patch (754 bytes) - added by aheckmann 11 years ago.
Attaching the patch for jQuery.style

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by aheckmann

Attachment: fix.txt added

The fix

Changed 11 years ago by aheckmann

Attachment: jQuery.style.patch added

Attaching the patch for jQuery.style

comment:1 Changed 10 years ago by john

Component: unfilledcore

comment:2 Changed 10 years ago by yehuda

Resolution: fixed
Status: newclosed

comment:3 Changed 9 years ago by snover

#7101 is a duplicate of this. Seems the original patch did not quite catch all potential clobbering situations.

Note: See TracTickets for help on using tickets.