Bug Tracker

Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#4661 closed bug (fixed)

$().toggle() does not work with <tr> in IE 8

Reported by: mz Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I want to use a link in order to show or hide a particular table row. I use $().toggle() to do this. This works in every browser except in IE 8, where the 'show' part of the toggle does nothing (the 'hide' part hides the table row as expected).

This bug does not happen when IE 8 runs in IE 7 mode ('Compatibility View'). And it does not happen with jQuery 1.3.1, so it seems to be a regression.

This bug is maybe related to ticket #4594.

I have provided a simple test case to show this problem.

Attachments (1)

toggleTableRowInIE8.html (1.3 KB) - added by mz 11 years ago.
Test case for this bug

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by mz

Attachment: toggleTableRowInIE8.html added

Test case for this bug

comment:1 Changed 10 years ago by maikelcoke

Anyone fixed this bug?

comment:2 Changed 10 years ago by coopster

I believe this may have something to do with IE attribute ordering but I haven't the time to analyze any further myself. Two links that help:

http://blogs.msdn.com/ie/archive/2009/03/12/site-compatibility-and-ie8.aspx http://www.code-styling.de/english/jquery-132-causes-problems-at-ie-8

comment:7 in reply to:  description Changed 10 years ago by TylerRick

This was affecting me with 1.3.2, but seems to fixed in 1.4.1. Yay!

comment:12 Changed 10 years ago by dmethvin

Component: unfiledfx
Resolution: fixed
Status: newclosed

I can't repro this in 1.4.2 so I'm closing it as fixed.

Note: See TracTickets for help on using tickets.