Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#4659 closed bug (worksforme)

IE 7 bind listening bug with "change" event

Reported by: benford Owned by: brandon
Priority: major Milestone: 1.4.2
Component: event Version: 1.4.1
Keywords: event, change, bind Cc:
Blocked by: Blocking:

Description

When bind-ing to a radio button with the "change" event listener, IE 7 behaves as normal, except that the event trigger does not occur until focus leaves the radio button.

On Firefox (3.x), Safari (3.x) and Opera (96) the event will trigger as soon as the radio button is selected, not waiting until focus leaves the selected radio button.

Changing the event to another type, such as "click" restores expected behavior.

This bug might be present in other versions of IE, but have only tested this on IE 7 so far.

Change History (5)

comment:1 Changed 10 years ago by kayakr

This issue occurs for me on IE8, except it requires not just a change of focus, but to click elsewhere on the page.

comment:2 Changed 9 years ago by Standart

http://dev.jquery.com/ticket/5658 is a duplicate of this ticket which gives some more hints. Basically, the possible fixes are described here: http://stackoverflow.com/questions/208471/getting-jquery-to-recognise-change-in-ie

To me the one utilizing 'propertychange' (http://stackoverflow.com/questions/208471/getting-jquery-to-recognise-change-in-ie/1639696#1639696) looks best.

comment:4 Changed 9 years ago by john

Milestone: 1.41.4.2
Resolution: worksforme
Status: newclosed
Version: 1.3.21.4.1

This was fixed in jQuery 1.4-1.4.2.

comment:5 Changed 8 years ago by Kyle Florence <kyle.florence@…>

Select elements with the "multiple" attribute seem to still be having some issues in IE (versions 6 and 7, at least, haven't tried 8) -- the "change" event only fires half the time. Not sure if it would help, but my workaround for all these issues is here: https://gist.github.com/770449

Note: See TracTickets for help on using tickets.