Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4653 closed bug (duplicate)

$("form").submit() doesn't work with named submit buttons

Reported by: ptarjan Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: form submit Cc:
Blocked by: Blocking:

Description

If the <form> has a <input type="submit" name="abc" value="click me"/> then calling $("form").submit() won't trigger the form submission.

Example: http://paulisageek.com/tmp/jquery-form-bug.html

Tested on

OSX 10.5 FF3.0.10 WinXP SP3 FF3.0.10

Change History (2)

comment:1 Changed 11 years ago by ptarjan

duplicate of 4652, sorry.

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.